You may not post on this forum because you're not logged in.

#1 18-Mar-2012 21:02:01

Sc0tTy
Member
Registered: 23-Dec-2011
Posts: 5

Windows 8 Colemak Fix

Hey All,

I just wanted to let you guys know how to have Windows 8 use Colemak as the primairy input layout after a reboot.
For some reason Microsoft removed this abitity in the GUI app for Layout switching.

Anyway here is it:
Step 1:
Install Colemak as usual :)
It will look like this: 23vywpi.png

Step 2:
Fire up regedit and go to: HKEY_CURRENT_USER\Keyboard Layout\Preload
It will look like this: 1tpnus.png

Step 3:
Rename key "1" to "2" and key "2" to "1" (please not that u probably need to give one a temp name since double keynames arn't allowed)
It will look like this: 1z3xwl5.png

Now just reboot and let the magic of Colemak run free on your Windows 8 :)

Sc0tTy

Offline

#2 19-Mar-2012 17:50:40

pinkyache
Member
Registered: 21-Apr-2010
Posts: 649

Re: Windows 8 Colemak Fix

Good God.  Yawn.  Yet more registry fiddling!

@Scotty, how does one 'install Colemak as usual'?

Last edited by pinkyache (19-Mar-2012 17:51:10)


--
Physicians deafen our ears with the Honorificabilitudinitatibus of their heavenly Panacaea, their sovereign Guiacum.

Offline

#3 19-Mar-2012 22:08:26

pafkata90
Member
From: Aalborg, Denmark
Registered: 05-Mar-2011
Posts: 387

Re: Windows 8 Colemak Fix

I beg to differ. The option to chose the layout on the welcome screen is still there. Control Panel → Language → Advanced Settings and under the Override for Windows Default Language choose "Use language list (recommended)" and then click "Apply language settings to the welcome screen...". Then under the administrative tab click Copy Settings. It's much easier to find than it looks by this post. I haven't used Windows 8 at all and it took me less than a minute.

Offline

#4 21-Mar-2012 23:15:47

Sc0tTy
Member
Registered: 23-Dec-2011
Posts: 5

Re: Windows 8 Colemak Fix

Don't want to copy it to the welcome screen in a multi user environment and also in Win7 it would remember per user which it does not in Win8 (thats the entire problem...)

@pinkyache Run installer?

Offline

#5 10-Sep-2012 10:38:47

pinkyache
Member
Registered: 21-Apr-2010
Posts: 649

Re: Windows 8 Colemak Fix

What I meant is I don't know what you mean by installer.  Either way I'd prefer not to have to run mysterious non-trusted binary-blobs on my computer if possible.

Last edited by pinkyache (29-Jan-2013 14:30:08)


--
Physicians deafen our ears with the Honorificabilitudinitatibus of their heavenly Panacaea, their sovereign Guiacum.

Offline

#6 05-Dec-2012 21:03:25

WorldMaker
Member
Registered: 17-Apr-2007
Posts: 11

Re: Windows 8 Colemak Fix

The trick to the Windows 8 is that the order of languages/keyboards matters just like the old screen, but its less obvious since they dropped the move up/down buttons and you have to just guess that you can reorder them.

Offline

#7 29-Jan-2013 14:45:19

pinkyache
Member
Registered: 21-Apr-2010
Posts: 649

Re: Windows 8 Colemak Fix

@worldmaker, not sure though how to re-order these if you have one language and multiple input methods.  I guess you have to set a default under Advanced settings.


--
Physicians deafen our ears with the Honorificabilitudinitatibus of their heavenly Panacaea, their sovereign Guiacum.

Offline

#8 18-Mar-2013 03:29:12

WorldMaker
Member
Registered: 17-Apr-2007
Posts: 11

Re: Windows 8 Colemak Fix

Huh, when I wrote that I believe both layouts showed up as different "languages" which are re-orderable and order does matter. Now they appear the same but you are right, I've got Colemak set as the default under Advanced Settings.

Offline

#9 09-Apr-2013 10:50:03

caspersoong
Member
Registered: 03-Apr-2013
Posts: 8

Re: Windows 8 Colemak Fix

I just deleted all the other layouts, which forced Colemak to be the input method.

Offline

Board footer