• You are not logged in.
  • Index
  • Technical
  • Bug in Windows version (VK F and W switched)

    Bug in Windows version (VK F and W switched)

    • Started by heron
    • 2 Replies:
    • Reputation: 0
    • From: San Francisco
    • Registered: 12-Jan-2007
    • Posts: 5

    Hi Shai

    The VK-codes of W and F in the Colemak.klc are switched. I don't know if the MSI or the .exe-files contain the bug as well since I could not use those. You can verify this easily by playing Letters with the driver installed.

    Many thanks for the layout including Vim support. I'm currently switching from a custom Dvorak-layout for the Kinesis Contoured to Colemak ;)

    Keep up the good work.
    Dan

    PS: do you also have to manually insert the first four bytes in a .klc after editing?

    Offline
    • 0
    • Shai
    • Administrator
    • Reputation: 7
    • Registered: 11-Dec-2005
    • Posts: 380

    No, the MSI and EXE don't contain that bug. I've fixed the KLC file in the Windows download, it should be okay now.

    The first two bytes are the Unicode BOM, so it can be automatically recognized as a Unicode file. I haven't checked if it's needed or not.

    If you're trying to edit it with Vim, you can add the following line to your .vimrc so it automatically handles the Unicode encoding and BOM when editing .KLC files:

    au BufNewFile,BufReadPre *.klc     set encoding=ucs-2 | setlocal fileencoding=ucs-bom | set guifont=Lucida_Console:h10 | set nowrap
    Offline
    • 0
    • Reputation: 0
    • From: San Francisco
    • Registered: 12-Jan-2007
    • Posts: 5

    thx for the swift response. I'll try the Vim settings the next time I'm tinkering with KLC.

    The MSI now works for me as well ;)

    Last edited by heron (12-Jan-2007 13:35:59)
    Offline
    • 0
      • Index
      • Technical
      • Bug in Windows version (VK F and W switched)