• You are not logged in.

    Help wanted in fixing a VirtualBox bug

    • Started by GeneralFailer
    • 12 Replies:
    • Reputation: 0
    • Registered: 13-Sep-2017
    • Posts: 7

    You can see the issue report here. In short, VirtualBox's guest control can't handle both Colemak and Shift+Shift being mapped as Caps Lock.
    If anyone has the know-how needed for fixing this, help would be appreciated.

    Offline
    • 0
    • Reputation: 46
    • From: Oslo, Norway
    • Registered: 13-Dec-2006
    • Posts: 4,026

    Hmmm. I just install my Big Bag for XKB on the guest system, it seems to work fine. I don't think this is really a VirtualBox problem but a problem of the guest OS? More specifically, you may be using a bad layout file (the Colemak layout, properly, shouldn't set the CapsLock function but leave that to options on XKB).

    Note that in the Big Bag, Extend mapping is the most common choice for CapsLock. In this case, Caps+Esc is CapsLock.

    Last edited by DreymaR (13-Sep-2017 20:34:57)

    *** Learn Colemak in 2–5 steps with Tarmak! ***
    *** Check out my Big Bag of Keyboard Tricks for Win/Linux/TMK... ***

    Online
    • 0
    • Reputation: 0
    • Registered: 13-Sep-2017
    • Posts: 7

    I'm using the vanilla xkb layout file. In my experience, those remap Caps Lock to Backspace when set as the default layout. I've tried the Big Bag in Ubuntu 16.04 yesterday, but ended up with an unmapped keyboard like here.

    Offline
    • 0
    • Reputation: 46
    • From: Oslo, Norway
    • Registered: 13-Dec-2006
    • Posts: 4,026

    Did you install the Big Bag by running my install script with sudo privileges?

    It may well be that the default Colemak layout tampers with the CapsLock key. If you want to use it nevertheless, just comment out those lines in its symbols file.

    *** Learn Colemak in 2–5 steps with Tarmak! ***
    *** Check out my Big Bag of Keyboard Tricks for Win/Linux/TMK... ***

    Online
    • 0
    • Reputation: 0
    • Registered: 13-Sep-2017
    • Posts: 7

    Never mind, I didn't install it properly then. Big Bag doesn't influence the behavior of the default Colemak for me.

    EDIT: The Shift+Shift setting refuses to work completely with Colemak[eD].

    Last edited by GeneralFailer (14-Sep-2017 19:41:03)
    Offline
    • 0
    • Reputation: 46
    • From: Oslo, Norway
    • Registered: 13-Dec-2006
    • Posts: 4,026

    The Big Bag installs new layouts, and doesn't interfere with the inferior ones. ;-)

    Colemak[eD] shouldn't interfere with Shift+Shift, but some of the options you get from the setxkb script may. If you have Extend activated, it will likely mess with Shift+Shift. But then as mentioned, you'll have another way of getting CapsLock.

    I strongly recommend Extend as it's simply great. But if you don't want it (yet) just don't activate it. Check out which options your setxkbmap config has (run it at -v 9 or so for a verbose output).

    Last edited by DreymaR (16-Sep-2017 14:03:03)

    *** Learn Colemak in 2–5 steps with Tarmak! ***
    *** Check out my Big Bag of Keyboard Tricks for Win/Linux/TMK... ***

    Online
    • 0
    • Reputation: 0
    • Registered: 13-Sep-2017
    • Posts: 7

    It seems Big Bag also set the model to pc101.

    Here's the output with broken (as in "not working") Shift+Shift:

    rules:      evdev
    model:      pc104
    layout:     us,us,ru
    variant:    cmk_ed_us,,
    options:    grp_led:scroll,grp:lctrl_lshift_toggle,shift:both_capslock
    Trying to build keymap using the following components:
    keycodes:   evdev+aliases(qwerty)
    types:      complete
    compat:     complete+ledscroll(group_lock)
    symbols:    pc+us(cmk_ed_us)+us:2+ru:3+inet(evdev)+group(lctrl_lshift_toggle)+shift(both_capslock)
    geometry:   pc(pc104)
    Last edited by GeneralFailer (16-Sep-2017 16:27:57)
    Offline
    • 0
    • Reputation: 46
    • From: Oslo, Norway
    • Registered: 13-Dec-2006
    • Posts: 4,026

    If you want an Ergo mod such as (Curl)AngleWide, you should set its model with my setxkb script. You can have it write a line to your .bashrc file if you wish.

    You didn't get pc101, but pc104. Well, not a big difference. What's your board, and which Ergo mods, if any, do you want?

    Doesn't seem that you have Extend active but I'd be wary of lctrl_lshift_toggle if I were you! I don't think you can use both that and shift:both_capslock at the same time. These options aren't from the Big Bag, but may get set by the setxkb script. Run it with -h to see how it's set.

    Setxkb will clear the XKB options before setting them. But if you run setxkbmap -o <option(s)> it'll just add to the existing option set. Be aware of this.

    Last edited by DreymaR (16-Sep-2017 14:21:28)

    *** Learn Colemak in 2–5 steps with Tarmak! ***
    *** Check out my Big Bag of Keyboard Tricks for Win/Linux/TMK... ***

    Online
    • 0
    • Reputation: 0
    • Registered: 13-Sep-2017
    • Posts: 7

    That one is mine. Setting it to Alt-Shift at least doesn't change anything.

    EDIT: I'd like to stay as vanilla as possible. The enhancements don't seem worth the hassle.

    Last edited by GeneralFailer (16-Sep-2017 14:27:10)
    Offline
    • 0
    • Reputation: 46
    • From: Oslo, Norway
    • Registered: 13-Dec-2006
    • Posts: 4,026

    Mmmm, not making sense that I can see?

    GeneralFailer said:

    That one is mine. Setting it to Alt-Shift at least doesn't change anything.

    EDIT: I'd like to stay as vanilla as possible. The enhancements don't seem worth the hassle.

    What one is yours?

    Vanilla, meaning...? Which board do you have (ANSI/pc104 or ISO/pc105 or...?)?

    If you have an Euro board (pc105) I strongly recommend at least the Angle mod. It's almost a standard, blessed by Shai himself.

    Last edited by DreymaR (16-Sep-2017 17:15:49)

    *** Learn Colemak in 2–5 steps with Tarmak! ***
    *** Check out my Big Bag of Keyboard Tricks for Win/Linux/TMK... ***

    Online
    • 0
    • Reputation: 0
    • Registered: 13-Sep-2017
    • Posts: 7

    You've heavily edited your reply after I read it. I was talking about Ctrl-Shift mapping. Vanilla Colemak. I have pc104.

    Offline
    • 0
    • Reputation: 46
    • From: Oslo, Norway
    • Registered: 13-Dec-2006
    • Posts: 4,026

    Ah, I see then. Yes, I do tend to think of something else after I've posted. Usually right after, but... ;-)

    In that case, your keyboard model is the one you want (pc104), isn't it?

    And the layouts look mostly okay. As mentioned, maybe the attempt at double-mapping Shift will get you in trouble; not sure.

    One thing to be aware of is that XKB doesn't always play nice with the alternative layouts. So you should have your go-to layout in slot 1 and not rely on the others much. I may use them for, say, a Greek phonetic layout for the occasional foreign-language typing, but not as main layouts. But I take it your problems were seen with layout 1 active?

    *** Learn Colemak in 2–5 steps with Tarmak! ***
    *** Check out my Big Bag of Keyboard Tricks for Win/Linux/TMK... ***

    Online
    • 0
    • Reputation: 0
    • Registered: 13-Sep-2017
    • Posts: 7

    I had corrected it, hence "also".

    Yep.

    Offline
    • 0