• You are not logged in.
  • Index
  • Technical
  • Fixes for common issues with switching keyboard layouts on Windows 10

    Fixes for common issues with switching keyboard layouts on Windows 10

    • Started by NottNott
    • 2 Replies:
    • Reputation: 21
    • Registered: 03-Feb-2018
    • Posts: 105

    I've encountered a few issues while installing keyboard layouts native to Windows (sorry AutoHotKeyers!) and I'd like to write something so other people don't get stuck like I did. This might also apply to other versions of Windows.

    1. After installing new layout, the keyboard switcher isn't there.

    The old control panel way of switching keyboards in Windows 7 and below doesn't have this problem - but it's not enabled by default. This issue only seems to affect keyboard layouts that you install, not ones already on the system. Go to the control panel (not the new Windows 10 settings menu, you have to search for 'control panel'), and go to 'Change input methods'. Then advanced settings in the sidebar to the left.
    40ade4cec279239cbdf0ec6a8337078d.png d36019bded1ddd743bcf036cb5c88334.png

    Tick 'Use the desktop language bar when it's available'. You'll probably have to restart your computer now, but it'll be there on the next login.

    65cb6db6f6fc6823c6b10cb82758fccc.png

    Alternatively: press Win+Space to switch between keyboard layouts using the new keyboard switcher. This will work even if the icon isn't in the bottom-right. If this does not work initially, try restarting your computer.

    2. How do I disable Ctrl+Shift changing my keyboard layout?
    In the advanced settings of input methods (see above), under 'Override for default input method' click 'Change language bar hot keys'

    06731bb499e11658a0e5ecfc7db182be.png

    Then 'Change key sequence' in the bottom right.

    a32dde88eda6fb13ccdf5d8aeb55e024.png

    Change accordingly.

    99044f5dffbc32a6ad0674d490a5a23d.png

    3. After I log in, the keyboard is set to QWERTY - how do I make it Colemak by default?

    Advanced settings of input methods yet again (see above). Change the 'Override for default input method' to Colemak.

    06731bb499e11658a0e5ecfc7db182be.png

    4. How do I make Colemak the default on the lock screen and for new user accounts? 

    Make sure you know how to type your password in Colemak, or make sure that QWERTY is still accessible as a keyboard layout on the lockscreen by having it as an enabled keyboard layout! Don't get locked out of your own machine!

    Once again in the advanced settings of input methods (see above). Click 'Apply language settings to the welcome screen, system accounts and new user accounts'
    1717f978fab89764d3ec6d6586e5569f.png

    Click 'Copy settings'.

    52a83aca411947e459ceed919e5c3488.png

    Tick the two checkboxes below as appropriate for what you'd like.

    b2006395c5483ba10868a7b29ead813f.png

    Hope this can help somebody, as it was confusing for me to figure all of this out at the time. If these problems don't affect you for whatever reason, consider yourself lucky!

    Last edited by NottNott (17-Apr-2018 16:13:16)
    Offline
    • 1
    • Reputation: 90
    • From: Oslo, Norway
    • Registered: 13-Dec-2006
    • Posts: 4,501

    Nice writeup! :-)

    You could mention that the logon layout affects passwords so you may have to use an invariant one or learn to type your password in both layouts.

    Also, instead of the "between layouts" hotkey I often use Ctrl+Shift+1 and 2 to get to the layouts. But nowadays I use Win+Space to cycle layouts as that's convenient.

    *** Learn Colemak in 2–5 steps with Tarmak! ***
    *** Check out my Big Bag of Keyboard Tricks for Win/Linux/TMK... ***

    Offline
    • 0
    • Reputation: 21
    • Registered: 03-Feb-2018
    • Posts: 105
    DreymaR said:

    You could mention that the logon layout affects passwords so you may have to use an invariant one or learn to type your password in both layouts.

    Done!

    DreymaR said:

    Also, instead of the "between layouts" hotkey I often use Ctrl+Shift+1 and 2 to get to the layouts. But nowadays I use Win+Space to cycle layouts as that's convenient.

    Win+Space uses the newer Windows keyboard layout switcher. For some reason when QWERTY and an installed Colemak layout is enabled, the bottom-leftright icon doesn't appear for some reason. This didn't happen with layouts already installed on Windows. That's why I enabled the control panel switcher - I thought the layout wasn't being treated fairly by the OS. Now I know I can just press Win+Space to switch layouts, and that works fine even though the indicator doesn't appear in the bottom. I'll adjust the guide accordingly.

    Last edited by NottNott (17-Apr-2018 16:13:04)
    Offline
    • 0
      • Index
      • Technical
      • Fixes for common issues with switching keyboard layouts on Windows 10