• You are not logged in.

    Strange Alt Behavior?

    • Started by krillcount
    • 4 Replies:
    • Reputation: 0
    • Registered: 01-Dec-2018
    • Posts: 3

    I'm a Windows user in North America. I was trying to use the ctrl+alt+v shortcut in Microsoft Excel (which is "paste special" in the latest version) and found that instead of getting the paste special dialog, I was getting the œ character as a result of the ctrl+alt+v combo. Interestingly, left alt+v does not map to œ, but ctrl+lalt+v does. By contrast, right alt+v maps directly to œ (no need to hit ctrl).

    I don't really have much need to type characters like that often enough for this to trump the usefulness of standard keyboard shortcuts, but I'm not really sure how to fix it.

    My best guess is that it has to do with the existence of the œ? I'm not really sure.

    Any ideas about how to fix this?

    In summary, I want Left Control + Left Alt + v to register as just that, but instead it registers as œ.

    Edit: I think I solved the problem for myself by just using MSKLC to create a new Colemak keyboard layout based on this one. I just removed all the AltGr keys. I think it should work now.

    Last edited by krillcount (01-Dec-2018 20:28:57)
    Offline
    • 0
    • Reputation: 90
    • From: Oslo, Norway
    • Registered: 13-Dec-2006
    • Posts: 4,505

    Were you using the MSKLC install beforehand? You didn't specify that.

    Ctrl+LAlt should not be AltGr; LCtrl+RAlt should. So if you tried the latter plus V you'd not get your shortcut. If the layout is set to have RAlt=AltGr, then RAlt will always activate the AltGr layers (state 6/7, in MSKLC terms). LAlt should not activate them under any circumstance.

    If I may make a personal suggestion, you could try PKL_eD. See my Big Bag. Then you'd have the wonderful Extend capability, among other things. If you don't want any AltGr behavior, there are VirtualKey layouts that don't add extra mapping layers.

    Last edited by DreymaR (03-Dec-2018 15:47:01)

    *** Learn Colemak in 2–5 steps with Tarmak! ***
    *** Check out my Big Bag of Keyboard Tricks for Win/Linux/TMK... ***

    Offline
    • 0
    • Reputation: 0
    • Registered: 01-Dec-2018
    • Posts: 3

    I wasn't using the MSKLC before, actually. I was using the basic installation for Windows from here. I found that left alt + left control + v gave the oe ligature character (as did right alt + v). I used MSKLC to edit the colemak layout and remove all the alternate / international characters as a workaround.

    Offline
    • 0
    • Reputation: 90
    • From: Oslo, Norway
    • Registered: 13-Dec-2006
    • Posts: 4,505

    The basic install for Windows is made with MSKLC. ;-)

    I haven't used it in a while but that does sound wrong. Maybe it's an ANSI vs ISO keyboard thing. There's also a setting in MSKLC for the AltGr behavior. But again, I'd recommend looking at PKL_eD. With that, you can just use your normal out-of-the-box layout install and run a program instead, which is great for when you need to type on other computers (as long as you're allowed to run programs on them). Also, should PKL_eD interfere with anything you can quite easily suspend and reactivate it.

    Last edited by DreymaR (03-Dec-2018 16:14:15)

    *** Learn Colemak in 2–5 steps with Tarmak! ***
    *** Check out my Big Bag of Keyboard Tricks for Win/Linux/TMK... ***

    Offline
    • 0
    • Reputation: 0
    • Registered: 01-Dec-2018
    • Posts: 3

    Ah ha! Well thanks for that - I'll check it out!

    Offline
    • 0