• You are not logged in.
  • Index
  • Technical
  • Issues with AltGr+Shift combos (can't type Ú Í Ó)

    Issues with AltGr+Shift combos (can't type Ú Í Ó)

    • Started by protocactus
    • 2 Replies:
    • Reputation: 0
    • Registered: 29-Dec-2018
    • Posts: 3

    Hi! First time posting here.

    While working on a modification to Rulemak in MSKLC that has support for both Slavic and non-Slavic languages, I've run into an issue with AltGr+Shift combos, namely that certain combos don't seem to work. For the QWERTY keys of U, I, O, H, and N, AltGr+Shift combos do not produce the assigned letter. Switching over to the regular Colemak (no-caps) layout, I realized that this the case in the normal layout as well, just with Colemak letter positions: it's impossible to type capital versions of the letters ú, í, and ó without resorting to the separate acute accent dead key (try for yourself). This also is troublesome because it means that the capital versions of 5 different letters (љ ү ї џ and қ for my layout) are impossible to type.

    Are there any fixes to this issue? It seems to me that this might be some sort of shortcut conflict issue (even though nothing happens at all when I press the combinations in question); if this is the case, is there a way to disable those specific shortcuts in Windows? I'm running Windows 8.1.

    Thanks for any help!

    Last edited by protocactus (29-Dec-2018 02:48:28)
    Offline
    • 0
    • Reputation: 15
    • From: Belgium
    • Registered: 26-Feb-2008
    • Posts: 448

    Not a Windows user (only at work, with PKL), so I can't help with your MSKLC question, but can you share your Rulemak layout? Which non-Slavic alphabets does it support?  (Perhaps respond in the Rulemak topic, to keep this topic for the technical issue.)

    Last edited by ghen (29-Dec-2018 18:35:40)
    Offline
    • 0
    • Reputation: 106
    • From: Oslo, Norway
    • Registered: 13-Dec-2006
    • Posts: 4,661

    Hmmm, sounds odd. Have you checked the level 7 (AltGr+Shift) mappings in MSKLC? In the .klc file? Could it be remedied by remapping these positions using MSKLC?

    Failing that, could it be something with your system? I haven't got the standard Colemak install installed so I can't try it, but I haven't heard of anyone else experiencing this problem.

    Last edited by DreymaR (31-Dec-2018 18:22:35)

    *** Learn Colemak in 2–5 steps with Tarmak! ***
    *** Check out my Big Bag of Keyboard Tricks for Win/Linux/TMK... ***

    Offline
    • 0
      • Index
      • Technical
      • Issues with AltGr+Shift combos (can't type Ú Í Ó)