• You are not logged in.

    Left arrow not working

    • Started by pegasusearl
    • 8 Replies:
    • Reputation: 0
    • Registered: 19-Jan-2019
    • Posts: 5

    Hello I'm using manjaro XFCE. I can't get the layout to work properly.

    First try i was using XFCE keyboard setting but the caps lock wont work similiar to this: https://forum.colemak.com/topic/287-bac … backspace/

    then I was reading: https://colemak.com/Unix
    and followed Linux/Unix in graphical mode using xorg.conf (X.Org Server 7.0 or later)
    But at the part: Type: sudo cp xorg/colemak /etc/X11/xkb/symbols/colemak (if this gives you an error the X11 configuration files might be located in a different directory)
    it gave error so its not in that directory but I tried to look where is it but I can't find it so I forgot about it and tried last attempt:

    Linux/Unix in graphical mode using xmodmap
    This one works, capslock backspace works. but arrow key doesn't. Haven't test the other key, it pobably has problem with other key as well?
    What should I do now to make it work properly?

    I have no idea.

    Anyone else using manjaro/arch XFCE?

    Last edited by pegasusearl (19-Jan-2019 11:57:38)
    Offline
    • 0
    • Reputation: 93
    • From: Oslo, Norway
    • Registered: 13-Dec-2006
    • Posts: 4,543

    Sorry, not sure how much I can help with that. But: In Linux, the CapsLock functionality shouldn't be part of the layout but a separate option.

    Also, have you checked out my Big Bag topic for Linux/XKB?

    Last edited by DreymaR (20-Jan-2019 18:44:19)

    *** Learn Colemak in 2–5 steps with Tarmak! ***
    *** Check out my Big Bag of Keyboard Tricks for Win/Linux/TMK... ***

    Offline
    • 0
    • Reputation: 0
    • Registered: 19-Jan-2019
    • Posts: 5

    First, thank you for answering.

    DreymaR said:

    Sorry, not sure how much I can help with that. But: In Linux, the CapsLock functionality shouldn't be part of the layout but a separate option.

    What does that mean? If I install following tutorial in wiki, it also did the capslock. And if I change configuration in my keyboard settings, there is such thing as separate option for capslock.

    DreymaR said:

    Also, have you checked out my Big Bag topic for Linux/XKB?

    I tried to read it but there is just so much thing I don't understand. And I don't understand how that would help me, can you point out exactly which part? It's really long, I can't possibly read everything and understand everything. I just want a colemak layout that working properly, not tips and tricks.

    Last edited by pegasusearl (21-Jan-2019 08:58:22)
    Offline
    • 0
    • Reputation: 93
    • From: Oslo, Norway
    • Registered: 13-Dec-2006
    • Posts: 4,543

    This wiki is a bit outdated and it doesn't tell you nearly everything about Linux for sure! :-)

    The main reason I prefer a Big Bag install over an "easy" one is that it gives me Extend. Check out what Extend is, it's as good as Colemak itself IMNSHO. But that aside...

    If you don't have an option for CapsLock function in the keyboard options of your distro, that basically means that your Settings GUI sucks. And for many distros that is unfortunately the case. If you read the "XKB CONFIGURATION" part of my Big Bag for XKB topic it should help a little. But to find the option you want you may have to look in for instance a rules/evdev.lst file – have one in my Big Bag for XKB repo. For instance, the command...

    setxkbmap -v 9 -option caps:backspace

    ...turns Caps into a Backspace. You may add that command to your ~/.bashrc file or whatever your distro uses, or edit the /etc/default/keyboard file as I describe.

    But you have to face the fact that Linux isn't always easy... ;-)

    However, I'm not sure I understand your problem. In standard XKB there's a us(colemak) layout variant that has CapsLock = Backspace in it:

        key <CAPS> { [    BackSpace,    BackSpace,       BackSpace,        BackSpace ] };

    Are you saying that layout variant didn't work for you? It's become standard after the Cmk Wiki was written.

    Last edited by DreymaR (22-Jan-2019 09:46:54)

    *** Learn Colemak in 2–5 steps with Tarmak! ***
    *** Check out my Big Bag of Keyboard Tricks for Win/Linux/TMK... ***

    Offline
    • 0
    • Reputation: 0
    • Registered: 19-Jan-2019
    • Posts: 5

    If you don't have an option for CapsLock function in the keyboard options of your distro, that basically means that your Settings GUI sucks.

    It probably is, I mean the XFCE as a DE. I found some post about how pain in the ass it is to set keyboard layout in xfce. I still use it because it's very fast, simple, customizable and doesn't come with bloatware.

    But you have to face the fact that Linux isn't always easy... ;-)

    I was always well aware of that :D

    However, I'm not sure I understand your problem. In standard XKB there's a us(colemak) layout variant that has CapsLock = Backspace in it:

    You mean in the GUI config? It works it just they have problems.

    Aside from the capslock is capslock and backspace button which is easily work arounded:
    If I used xkb it will always revert to qwerty everytime I switch window, if I used xmodmap with https://colemak.com/pub/unix/colemak-1.0.tar.gz it works well except left arrow does not. (I also used some other method that I forgot what it is, so let's not talk about that :lol: )

    After I search for a solution for a way, the best way is fixing the left button in https://colemak.com/pub/unix/colemak-1.0.tar.gz, I will probably report a bug to colemak team if they have any (I wish they just had a github repo for it.). This problem also happened ten years ago here: https://forum.colemak.com/topic/572-pro … -in-linux/ (it happened in ubuntu), his solution is changing to other method but in my case, it probably is the only method that would work properly.

    Last edited by pegasusearl (24-Jan-2019 14:25:19)
    Offline
    • 0
    • Reputation: 10
    • From: Belgium
    • Registered: 26-Feb-2008
    • Posts: 432
    pegasusearl said:

    It probably is, I mean the XFCE as a DE. I found some post about how pain in the ass it is to set keyboard layout in xfce. I still use it because it's very fast, simple, customizable and doesn't come with bloatware.

    You can also edit ~/.config/xfce4/xfconf/xfce-perchannel-xml/keyboard-layout.xml directly, which allows you to set exotic xkb options that are not available through GUI selection.

    If it still doesn't allow you to do what you want, then set XFCE keyboard settings to "Use system defaults", and configure your keyboard outside of XFCE, through setxkbmap commands in your .xinitrc, .xsession, or some session startup script.

    Offline
    • 0
    • Reputation: 0
    • Registered: 19-Jan-2019
    • Posts: 5
    ghen said:

    If it still doesn't allow you to do what you want, then set XFCE keyboard settings to "Use system defaults", and configure your keyboard outside of XFCE, through setxkbmap commands in your .xinitrc, .xsession, or some session startup script.

    I already tick use system default and reboot but using xkbmap still revert to qwerty everytime I switch to other window. From terminal to chromium for example.

    It's like this.
    I changed the layout through terminal, then it changed to colemak in terminal.
    I switch to chromium and it get reverted back to qwerty.
    When I switch back again to earlier terminal (the same exact terminal window), it's qwerty, not colemak.

    Last edited by pegasusearl (25-Jan-2019 11:48:10)
    Offline
    • 0
    • Reputation: 93
    • From: Oslo, Norway
    • Registered: 13-Dec-2006
    • Posts: 4,543

    Then you need your command in another startup script. I use .bashrc which means that every window gets the right layout for me.

    *** Learn Colemak in 2–5 steps with Tarmak! ***
    *** Check out my Big Bag of Keyboard Tricks for Win/Linux/TMK... ***

    Offline
    • 0
    • Reputation: 0
    • Registered: 19-Jan-2019
    • Posts: 5

    Hello, just for update regarding this problem. While I still haven't figured out the way to fix xmodmap method.

    The reverting to qwerty problem is caused by fcitx or possibly any other IME. Changing the config on the IME should do the job.

    I apologize for every annoyances I caused. Thank you.

    Offline
    • 0