• You are not logged in.

    Issues with Dreymar's BBKT [linux]

    • Started by tecosaur
    • 1 Replies:
    • Reputation: 0
    • Registered: 20-Apr-2019
    • Posts: 3

    Sorry about my technical posts in the BBKT topic, I've just noticed this forum.

    I'm afraid my technical issues are continuing.

    Recap:

    Also one unfortunate thing; I'm currently in the process of learning the Colemak-CAW (ANSI) layout and I've run into two issues:

    1. After running

    bash ./install-dreymar-xmod.sh -ox 4cw us

    (I'm on linux) and restarting wide mode … disappears

    2. After running

    bash ./install-dreymar-xmod.sh -ox 4cw us

    (and not restarting) my function keys (F1–12) don't work

    Other than that it's been great — I definitely feel more comfortable, if a little slower, and the extend mode is marvellous!
    I may only be typing at ~15 wpm now but it's going up! (this is the first message I've written in not-querty).

    Now for some better info

    - System:    Linux
    - Distro:       Solus
    - DE:           Budgie
    - Versions:  xmodmap=1.0.10, BBKT=current, kernel=5.0.7-114

    And some more interesting behaviour, it seems that just after activating the BBKT and removing and readding the Colemak-Curl(DH) +wide+angle the following happens:
    For a few seconds get the escape and function keys operating as expected

    image.pngimage.png

    However, after a few seconds, I get this from the escape and F1-12 keys

    image.png

    This is what my system settings keyboard switching page shows me

    image.png

    I would restart (not sure what effect that has, will let you know when I do), but as previously mentioned that messes up the layout.


    I'd love to get this working so any help would be appreciated.

    tecosaur.

    Last edited by tecosaur (22-Apr-2019 14:57:58)
    Offline
    • 0
    • Reputation: 106
    • From: Oslo, Norway
    • Registered: 13-Dec-2006
    • Posts: 4,661

    The restart thing is simple enough: After some crashes, I don't set your keyboard "model" for you in the system settings anymore. You can set the model to one of my Angle/Wide/Curl ones as suits you. But what I use on most machines is a .bashrc command (setxkbmap) that activates the right model on every logon. I find this robust and safe.

    If you run the setxkb -? command after installing (which you've done now), you see an option to generate such a line based on your selected model (4cw us us). If your distro doesn't use ~/.bashrc though, you must manually move the line into another relevant .rc file.

    The F# key problem doesn't ring a bell, I've never encountered that. You could always comment out the F# key mappings in the extend symbols file and live without the multimedia Extend keys. Try it at least to see if that affects your issue.

    You mention xmodmap, not sure if that can cause trouble? My mappings are for xkb. Have you done anything F# related with xmodmap? Any other apps/programs/scripts running that interfere with F# keys on your system?

    Last edited by DreymaR (23-Apr-2019 13:54:17)

    *** Learn Colemak in 2–5 steps with Tarmak! ***
    *** Check out my Big Bag of Keyboard Tricks for Win/Linux/TMK... ***

    Offline
    • 0