• You are not logged in.

    How do I disable alt-gr using MS KLC?

    • Started by mehgcap
    • 6 Replies:
    • Reputation: 0
    • Registered: 25-Sep-2019
    • Posts: 5

    As others have found before me, Colemak's remapping of right alt to alt-gr is more a hindrance than a help. I press alt-tab, alt-f4, alt-f, alt-e, and plenty of other hotkeys multiple times a day, but I never need to write any of Colemak's Unicode characters. I'd like to have Colemak, but without alt-gr.

    So far, I've installed Microsoft Keyboard Layout Creator. I've tried to edit the Colemak layout I have, and make my own.

    When I made my own, I mapped the letters and numbers easily enough, but hotkeys still default to standard. For instance, I can type qwerty's r, and get the expected p. However, if I press windows-r (qwerty's r), I get the Run dialog. Windows-s (qwerty's s) should result in Run under Colemak, but I get Windows-s instead. It's as though typing is Colemak, but all hotkeys are qwerty.

    When I edited the layout I already installed, I couldn't find a way to simply disable the alt-gr to right alt mapping. KLC doesn't show these modifiers, and I haven't yet worked out what to edit in the .klc file. Besides, I'm not sure how to manually compile the result even if I got the remapping right.

    I'd love it if the maintainer(s) of Colemak would just provide this variant by default. We already have one with caps lock set to backspace, and one without that modification, so making a simplified version without alt-gr should certainly be doable. In the meantime, can anyone tell me how to proceed? I've tried PKL already, but I couldn't find a keyboard-only way of getting out of it when I had problems. As a screen reader user who can't really use a mouse, having the fallback of a shortcut that tells Windows to go back to a different keyboard layout is essential. I would thus prefer to use KLC if possible.

    Offline
    • 0
    • Reputation: 111
    • From: Oslo, Norway
    • Registered: 13-Dec-2006
    • Posts: 4,675

    It's from the KLC menu, Project -> Properties -> Optional Settings. On a side note, there isn't really a dedicated AltGr modifier but this setting makes RAlt send RAlt+LCtrl instead. So with a layout that hasn't got AltGr you could still get any 4-level mappings by hitting LCtrl+RAlt+<key>. If you want that gone too, you'd have to set all keys in your layout as 2-level ones I guess.

    Using EPKL, to press Alt+F4 I instead press Extend+A+4 which can be hit without going far from the home position. That's nice. I also use Ext+T+4 (Ctrl+F4) to close browser tabs.

    If you do insist on making your own KLC file, you'll have to fix the Virtual Key codes manually in the file before compiling it in the GUI. The VK codes are in the second column for each key entry. Make sure you get the OEM_# ones right, as they depend on ANSI vs ISO. It affects backspace, slash, tilde and others. Try it out.

    Of course you'd love if the maintainers kept more variants. But there's really only one Shai and he doesn't maintain much. It'd be too much to ask I'm afraid. I maintain EPKL which is quite active.

    Last edited by DreymaR (25-Sep-2019 08:22:19)

    *** Learn Colemak in 2–5 steps with Tarmak! ***
    *** Check out my Big Bag of Keyboard Tricks for Win/Linux/TMK... ***

    Offline
    • 0
    • Reputation: 0
    • Registered: 25-Sep-2019
    • Posts: 5

    Thanks for getting back to me. When I open Colemak in KLC, I have Project > Properties, but there are no advanced options there. I have the text fields for details about the layout, the language list, a checkbox for shift lock, a checkbox for right/left markers, and that's all.

    Edit: After reading the help file for this dialog, I found out that the option is not there because the layout defines alt-gr keystrokes. You can't simply uncheck a box and thereby remove these mappings, you have to manually find and remove them all first, then you can uncheck the box. Off I go.

    I'm not worried about disabling characters entirely, so leaving the control-alt settings in place is fine. I'm just hoping to undo the setting that makes right alt send right alt + left control.

    Last edited by mehgcap (25-Sep-2019 11:13:45)
    Offline
    • 0
    • Reputation: 0
    • Registered: 25-Sep-2019
    • Posts: 5

    I've made my alternate layout, with no alt-gr mappings, but I'm still having the problem with hotkeys not using the new layout. I'm currently typing in Colemak, but Windows-p (win-r in QWERTY) opens the Run dialog. Other hotkeys also use QWERTY keys, despite my basic typing being all Colemak. I don't know why  this is happening. It only happens in my modified version, not the original.

    Offline
    • 0
    • Reputation: 111
    • From: Oslo, Norway
    • Registered: 13-Dec-2006
    • Posts: 4,675

    The hotkey problem is due to VK codes. Reread my answer, third paragraph please.

    Strange if you don't have the 'optional settings'? In my MSKLC, there's "Right Alt treated as...", then "CapsLock turned off..." then "L.Shift+Back =...". Try starting a new blank layout and see if you see those settings.

    Last edited by DreymaR (26-Sep-2019 09:43:25)

    *** Learn Colemak in 2–5 steps with Tarmak! ***
    *** Check out my Big Bag of Keyboard Tricks for Win/Linux/TMK... ***

    Offline
    • 0
    • Reputation: 0
    • Registered: 25-Sep-2019
    • Posts: 5

    The option re-appears so long as no keys in the layout have alt-gr mappings assigned. If any do, the option isn't present. I had to remove all the mappings manually, but I finally got the option to show up. It was unchecked, since I'd removed all the mappings that use it.

    As to the VK codes, I think I finally get it. Now my only problem is a KLC error saying that one of my codes is mapped twice. It's the mapping for the semicolon to o. KLC tells me that the same key is mapped twice:

    "VK_OEM_1 found at scan code 13 and 27"

    Scan code 27 in my file is this:

    27    Y        5    o    O    -1        // LATIN SMALL LETTER O, LATIN CAPITAL LETTER O,

    and scan code 13 is this:

    13    OEM_1        5    p    P    -1        // LATIN SMALL LETTER P, LATIN CAPITAL LETTER P,

    I'm not sure what happened here, but until I fix this, KLC refuses to build my layout. Any thoughts?

    Also, for anyone else interested, this blog post explains the VK problem well. I found it very helpful.

    http://www.sensefulsolutions.com/2010/0 … lc-eg.html

    Offline
    • 0
    • Reputation: 0
    • Registered: 25-Sep-2019
    • Posts: 5

    I've fixed the problem. It seems I had Y mapped incorrectly. Now, though, using my custom layout *still* sends alt-gr keystrokes with right alt, even though the option for that is unchecked in the properties. I don't get it. Is there a way to disable it in the .klc file, just to be sure it's really not mapped?

    Offline
    • 0