• You are not logged in.

    Help making layout

    • Started by CubeDude
    • 3 Replies:
    • Reputation: 0
    • Registered: 11-May-2023
    • Posts: 3

    Thanks for clicking!

    I use qwerty every day and have an average wpm of around 90. Today I decided to learn colemak. Found this nifty thing called the tarmak method. Downloaded this program called "epikal portable keyboard layout". Everything worked.

    However, I am used to my Dutch qwerty layout, where where a few symbols work differently. Sadly, There is no Dutch version of the Tarmak layouts.

    Because of that, I thought it'd make sense to make my own layout: I wanted to do this by taking the files for the Dutch colemak layout and then just changing the keys that I needed to change to effectively turn it into tarmak 1, since that seemed like the easiest option.
    However, I am very confused as to how I'm supposed to do this. I think the file I am looking for might be Layout.ini in EPKL_Executable_v1-4-1\Layouts\Colemak\Cmk-eD-Nl\Cmk-eD-Nl_ISO_CurlAWide, but even if that is correct I am not sure how I can alter the layout. The readme in EPKL_Executable_v1-4-1\Layouts did not help me.
    I'm very new to all of this. Can someone please help me?

    Last edited by CubeDude (11-May-2023 18:31:14)
    Offline
    • 0
    • Reputation: 213
    • From: Viken, Norway
    • Registered: 13-Dec-2006
    • Posts: 5,354

    Yeah, I obviously didn't take the time to make locale variants of all the Tarmak steps.

    What I'd do is take the Nl locale Layout.ini file (you chose the CurlAWide which doesn't exist as a Tarmak progression, but it should be okay for this purpose), and copy the key overrides in it to the Layout.ini file of each Tarmak step.

    So, this bit:

    [layout]
    ;;  Override keys from the base layout with mappings here. A "VK" entry resets that key.
    ;;
    ;shiftStates    =			0	:	1	:	2	:	6	:	7		;	8	:	9	:	e	:	f
    ;; SC = VKEY    	CStat	Base	Shift	Ctrl	AltGr	AGrSh	;	SwiSh	SwShS	SwAGr	SwAGS
    
    QW_LB = vc_LB   	0   	@0a8	@05e	&Esc	[   	{   	; US [{ (eD [{ åÅ) Nl ¨^
    QW_RB = vc_RB   	0   	@0b4	@060	--  	]   	}   	; US ]} (eD ]} æÆ) Nl ´`
    ;QW_LG = vc_LG   	5   	ij   	IJ   	--  	œ   	Œ   	; US <> (eD œŒ øØ) Nl ijIJ (Unicode)
    QW_L  = I       	1   	i   	I   	--  	→ij  	→IJ  	; QW lL (eD iI —→) Nl ijIJ (bigram)
    QW_H  = H       	5   	h   	H   	--  	ħ   	↓   	; QW hH (eD hH ħĦ) Nl ↓
    QW_M  = M       	1   	m   	M   	--  	×   	←   	; QW mM (eD mM ×↓) Nl ←
    QW_K  = E       	1   	e   	E   	--  	€   	→   	; QW kK (eD eE €←) Nl →

    Take that and add it to the [layout] section of each Layout.ini file in the Tarmak progression you're using. Such as this one:
    https://github.com/DreymaR/BigBagKbdTri … Layout.ini
    (That's if you use Tarmak-CurlAngle)

    *** Learn Colemak in 2–5 steps with Tarmak! ***
    *** Check out my Big Bag of Keyboard Tricks for Win/Linux/TMK... ***

    Online
    • 1
    • Reputation: 0
    • Registered: 11-May-2023
    • Posts: 3
    DreymaR said:

    Yeah, I obviously didn't take the time to make locale variants of all the Tarmak steps.

    What I'd do is take the Nl locale Layout.ini file (you chose the CurlAWide which doesn't exist as a Tarmak progression, but it should be okay for this purpose), and copy the key overrides in it to the Layout.ini file of each Tarmak step.

    So, this bit:

    [layout]
    ;;  Override keys from the base layout with mappings here. A "VK" entry resets that key.
    ;;
    ;shiftStates    =			0	:	1	:	2	:	6	:	7		;	8	:	9	:	e	:	f
    ;; SC = VKEY    	CStat	Base	Shift	Ctrl	AltGr	AGrSh	;	SwiSh	SwShS	SwAGr	SwAGS
    
    QW_LB = vc_LB   	0   	@0a8	@05e	&Esc	[   	{   	; US [{ (eD [{ åÅ) Nl ¨^
    QW_RB = vc_RB   	0   	@0b4	@060	--  	]   	}   	; US ]} (eD ]} æÆ) Nl ´`
    ;QW_LG = vc_LG   	5   	ij   	IJ   	--  	œ   	Œ   	; US <> (eD œŒ øØ) Nl ijIJ (Unicode)
    QW_L  = I       	1   	i   	I   	--  	→ij  	→IJ  	; QW lL (eD iI —→) Nl ijIJ (bigram)
    QW_H  = H       	5   	h   	H   	--  	ħ   	↓   	; QW hH (eD hH ħĦ) Nl ↓
    QW_M  = M       	1   	m   	M   	--  	×   	←   	; QW mM (eD mM ×↓) Nl ←
    QW_K  = E       	1   	e   	E   	--  	€   	→   	; QW kK (eD eE €←) Nl →

    Take that and add it to the [layout] section of each Layout.ini file in the Tarmak progression you're using. Such as this one:
    https://github.com/DreymaR/BigBagKbdTri … Layout.ini
    (That's if you use Tarmak-CurlAngle)

    Thanks for replying!
    I'm not sure why I went into the CurlAWide files, I use the default Tarmak haha. Seems like I should've been altering the layout.ini file in EPKL_Executable_v1-4-1\Layouts\Tarmak\Tmk-ISO\Tmk-VK-Tm2_ISO (since I'm currently using tarmak 2).

    However, doing this did not fix the problem I had with the keyboard - which I think I probably should have clarified in the first place. As it turns out, the problem I had had nothing to do with the language, but just with Tarmak.
    For example, when I press the ' key on the default tarmak, it doesn't appear at first, and when I press it again, 2 of those symbols appear at the same time. So far so good, since the same thing happens using a qwerty or colemak keyboard layout. However, If I press it once and then type a consonant, like for example r, it just types out the letter r, instead of typing out 'r. And if I follow it with a vowel, like for example e, it just gives me e instead of é. Same thing for the ` and " symbol.

    For some reason I thought that it was just that on a US keyboard symbols work differently, and that that's why it did that.
    When I realized this might not be the case at all, I enabled the "normal" US colemak, and sure enough, I can type é, è and ë on that one, just like on the Nl layout.

    I have now figured out that it has something to do with Tarmak only having a VK option, since I get the same problem when I use the VK layout type on colemak.

    I know this probably seems like a pretty stupid mistake, since I'm pretty sure this something quite basic. As I said I'm very new to all of this and really don't understand this program or how keyboard layouts and the associated files work very well. I've heard of dvorak and colemak before but other than that I only learned about this stuff existing yesterday, so please bear with me. Would it require a lot of effort to fix the problem I have with Tarmak?

    Offline
    • 0
    • Reputation: 213
    • From: Viken, Norway
    • Registered: 13-Dec-2006
    • Posts: 5,354

    That's the dead keys messing with you. Since that key is a dead key producing an accent on your underlying OS layout, you need to tell EPKL this. Seems that the auto detection didn't work, so use the Settings dialog (or find the settings file and edit it) and specify that the acute accent is a system dead key. Same for grave and umlaut accents. So, ´`¨ are your dead keys.

    I'm hoping to make automatic OS dead key detection work everywhere. It seems to be working for the eD2VK type layouts, so far.

    And no, it's not a stupid mistake by a long shot! This is fairly complex stuff.

    Last edited by DreymaR (15-May-2023 09:29:02)

    *** Learn Colemak in 2–5 steps with Tarmak! ***
    *** Check out my Big Bag of Keyboard Tricks for Win/Linux/TMK... ***

    Online
    • 0