• You are not logged in.
  • Index
  • Technical
  • Ubuntu 6.10 Edgy Eft - can't install colemak

    Ubuntu 6.10 Edgy Eft - can't install colemak

    • Started by sand
    • 3 Replies:
    • Reputation: 0
    • Registered: 06-Jul-2006
    • Posts: 12

    I've managed to get Colemak working on a few distros, but I'm struggling with Edgy.

    I've tried to set up Colemak on both a desktop and laptop, and both have identical problems.

    The install instructions for xmodmap work, but Xorg 7.0 doesn't. It gives this feedback:

    setxkbmap -v colemak && xset r 66
    Warning! Multiple definitions of keyboard layout
             Using command line, ignoring X server
    Trying to build keymap using the following components:
    keycodes:   xfree86+aliases(qwerty)
    types:      complete
    compat:     complete
    symbols:    pc(pc105)+colemak+level3(ralt_switch)
    geometry:   pc(pc105)
    Error loading new keyboard description

    It does this as regular user or as root (via sudo).

    Exact same error on desktop and laptop.

    Adding the lines to xorg.conf doesn't do anything either.

    Last edited by sand (06-Nov-2006 17:04:44)
    Offline
    • 0
    • Shai
    • Administrator
    • Reputation: 7
    • Registered: 11-Dec-2005
    • Posts: 380

    I did a fresh installation of Edgy and it works for me. Make sure you've typed the Perl command in the Linux/Unix installation instuctions correctly.

    Offline
    • 0
    • Reputation: 0
    • Registered: 06-Jul-2006
    • Posts: 12
    Shai said:

    I did a fresh installation of Edgy and it works for me. Make sure you've typed the Perl command in the Linux/Unix installation instuctions correctly.

    Cheers. All working now.

    Would have increased my chance of typing it correctly, if I'd actually typed it at all...

    sorry.

    Offline
    • 0
    • Shai
    • Administrator
    • Reputation: 7
    • Registered: 11-Dec-2005
    • Posts: 380

    In order to simplify things, I've removed the step requiring the Perl command line, so people shouldn't have this kind of problem in the future.

    Offline
    • 0
      • Index
      • Technical
      • Ubuntu 6.10 Edgy Eft - can't install colemak