• You are not logged in.

    How to get rid of AltGr mapping?

    • Started by makarov
    • 1 Replies:
    • Reputation: 0
    • Registered: 06-May-2019
    • Posts: 2

    I am using Windows 10. How can I disable AltGr in Colemak and return that key to RightAlt? I find Windows shortcuts that I can do with both hands to be more valuable than AltGr.

    Example shortcuts I use all the time are RightAlt + Tab for instant window toggle and RightAlt + F4 to close a window. Neither works with AltGr.

    I have tried SharpKeys but for some reason it barfs on AltGr, can't accept it for remapping. When I enter AltGr > RightAlt in SharpKeys, it seems to write it to the registry as RightAlt > RightAlt.

    Offline
    • 0
    • Reputation: 99
    • From: Oslo, Norway
    • Registered: 13-Dec-2006
    • Posts: 4,616

    Did you use the MSKLC installer? If so, that's set to use AltGr. You could edit the .klc file with MSKLC to set it to two-level, but that's a bit technical.

    Another option is to use EPKL instead. I could walk you through the how-to.

    This isn't an issue for SharpKeys a.k.a. registry remapping. The keyboard sends RAlt and the OS layout turns that into LCtrl+RAlt=AltGr, so you couldn't remap it away.

    Last edited by DreymaR (06-May-2019 08:28:45)

    *** Learn Colemak in 2–5 steps with Tarmak! ***
    *** Check out my Big Bag of Keyboard Tricks for Win/Linux/TMK... ***

    Offline
    • 0